summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/crates/profile
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rust-analyzer/crates/profile')
-rw-r--r--src/tools/rust-analyzer/crates/profile/Cargo.toml2
-rw-r--r--src/tools/rust-analyzer/crates/profile/src/lib.rs2
2 files changed, 2 insertions, 2 deletions
diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
index 937834a82..56ce9d11c 100644
--- a/src/tools/rust-analyzer/crates/profile/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/profile/Cargo.toml
@@ -14,8 +14,8 @@ doctest = false
[dependencies]
once_cell = "1.17.0"
cfg-if = "1.0.0"
-libc = "0.2.135"
la-arena.workspace = true
+libc.workspace = true
countme = { version = "3.0.1", features = ["enable"] }
jemalloc-ctl = { version = "0.5.0", package = "tikv-jemalloc-ctl", optional = true }
diff --git a/src/tools/rust-analyzer/crates/profile/src/lib.rs b/src/tools/rust-analyzer/crates/profile/src/lib.rs
index e7fc3d970..fdd724e2a 100644
--- a/src/tools/rust-analyzer/crates/profile/src/lib.rs
+++ b/src/tools/rust-analyzer/crates/profile/src/lib.rs
@@ -1,6 +1,6 @@
//! A collection of tools for profiling rust-analyzer.
-#![warn(rust_2018_idioms, unused_lifetimes, semicolon_in_expressions_from_macros)]
+#![warn(rust_2018_idioms, unused_lifetimes)]
mod stop_watch;
mod memory_usage;