summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/crates/sourcegen
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rust-analyzer/crates/sourcegen')
-rw-r--r--src/tools/rust-analyzer/crates/sourcegen/Cargo.toml2
-rw-r--r--src/tools/rust-analyzer/crates/sourcegen/src/lib.rs2
2 files changed, 2 insertions, 2 deletions
diff --git a/src/tools/rust-analyzer/crates/sourcegen/Cargo.toml b/src/tools/rust-analyzer/crates/sourcegen/Cargo.toml
index fb2b9ebef..0514af8e7 100644
--- a/src/tools/rust-analyzer/crates/sourcegen/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/sourcegen/Cargo.toml
@@ -12,4 +12,4 @@ rust-version.workspace = true
doctest = false
[dependencies]
-xshell = "0.2.2"
+xshell.workspace = true
diff --git a/src/tools/rust-analyzer/crates/sourcegen/src/lib.rs b/src/tools/rust-analyzer/crates/sourcegen/src/lib.rs
index 1514c6c7d..18fa77fd9 100644
--- a/src/tools/rust-analyzer/crates/sourcegen/src/lib.rs
+++ b/src/tools/rust-analyzer/crates/sourcegen/src/lib.rs
@@ -6,7 +6,7 @@
//!
//! This crate contains utilities to make this kind of source-gen easy.
-#![warn(rust_2018_idioms, unused_lifetimes, semicolon_in_expressions_from_macros)]
+#![warn(rust_2018_idioms, unused_lifetimes)]
use std::{
fmt, fs, mem,