summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/crates/syntax/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rust-analyzer/crates/syntax/Cargo.toml')
-rw-r--r--src/tools/rust-analyzer/crates/syntax/Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/tools/rust-analyzer/crates/syntax/Cargo.toml b/src/tools/rust-analyzer/crates/syntax/Cargo.toml
index 5ee0c4792..7a7c0d267 100644
--- a/src/tools/rust-analyzer/crates/syntax/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/syntax/Cargo.toml
@@ -14,16 +14,16 @@ doctest = false
[dependencies]
cov-mark = "2.0.0-pre.1"
-either = "1.7.0"
-itertools = "0.10.5"
-rowan = "0.15.11"
+either.workspace = true
+itertools.workspace = true
+rowan = "0.15.15"
rustc-hash = "1.1.0"
once_cell = "1.17.0"
-indexmap = "2.0.0"
+indexmap.workspace = true
smol_str.workspace = true
triomphe.workspace = true
-rustc_lexer.workspace = true
+rustc-dependencies.workspace = true
parser.workspace = true
profile.workspace = true
@@ -31,7 +31,7 @@ stdx.workspace = true
text-edit.workspace = true
[dev-dependencies]
-rayon = "1.6.1"
+rayon.workspace = true
expect-test = "1.4.0"
proc-macro2 = "1.0.47"
quote = "1.0.20"
@@ -41,4 +41,4 @@ test-utils.workspace = true
sourcegen.workspace = true
[features]
-in-rust-tree = []
+in-rust-tree = ["rustc-dependencies/in-rust-tree"]