summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile')
-rw-r--r--tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile b/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile
deleted file mode 100644
index 324791af8..000000000
--- a/tests/run-make-fulldeps/cdylib-fewer-symbols/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-# Test that allocator-related symbols don't show up as exported from a cdylib as
-# they're internal to Rust and not part of the public ABI.
-
-include ../tools.mk
-
-# ignore-windows
-# FIXME: The __rdl_ and __rust_ symbol still remains, no matter using MSVC or GNU
-# See https://github.com/rust-lang/rust/pull/46207#issuecomment-347561753
-
-all:
- $(RUSTC) foo.rs
- nm -g "$(call DYLIB,foo)" | $(CGREP) -v __rdl_ __rde_ __rg_ __rust_