summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-24445
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/issue-24445')
-rw-r--r--tests/run-make-fulldeps/issue-24445/Makefile10
-rw-r--r--tests/run-make-fulldeps/issue-24445/foo.c6
-rw-r--r--tests/run-make-fulldeps/issue-24445/foo.rs15
3 files changed, 0 insertions, 31 deletions
diff --git a/tests/run-make-fulldeps/issue-24445/Makefile b/tests/run-make-fulldeps/issue-24445/Makefile
deleted file mode 100644
index 2a12226a6..000000000
--- a/tests/run-make-fulldeps/issue-24445/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-include ../tools.mk
-
-# only-linux
-
-all:
- $(RUSTC) foo.rs
- $(CC) foo.c -lfoo -L $(TMPDIR) -Wl,--gc-sections -lpthread -ldl -o $(TMPDIR)/foo
- $(call RUN,foo)
- $(CC) foo.c -lfoo -L $(TMPDIR) -Wl,--gc-sections -lpthread -ldl -pie -fPIC -o $(TMPDIR)/foo
- $(call RUN,foo)
diff --git a/tests/run-make-fulldeps/issue-24445/foo.c b/tests/run-make-fulldeps/issue-24445/foo.c
deleted file mode 100644
index bb4036b06..000000000
--- a/tests/run-make-fulldeps/issue-24445/foo.c
+++ /dev/null
@@ -1,6 +0,0 @@
-void foo();
-
-int main() {
- foo();
- return 0;
-}
diff --git a/tests/run-make-fulldeps/issue-24445/foo.rs b/tests/run-make-fulldeps/issue-24445/foo.rs
deleted file mode 100644
index b67f3847c..000000000
--- a/tests/run-make-fulldeps/issue-24445/foo.rs
+++ /dev/null
@@ -1,15 +0,0 @@
-#![crate_type = "staticlib"]
-
-struct Destroy;
-impl Drop for Destroy {
- fn drop(&mut self) { println!("drop"); }
-}
-
-thread_local! {
- static X: Destroy = Destroy
-}
-
-#[no_mangle]
-pub extern "C" fn foo() {
- X.with(|_| ());
-}