summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/mixing-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/mixing-libs/Makefile')
-rw-r--r--tests/run-make-fulldeps/mixing-libs/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/mixing-libs/Makefile b/tests/run-make-fulldeps/mixing-libs/Makefile
new file mode 100644
index 000000000..39cc0708c
--- /dev/null
+++ b/tests/run-make-fulldeps/mixing-libs/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) rlib.rs
+ $(RUSTC) dylib.rs
+ $(RUSTC) rlib.rs --crate-type=dylib
+ $(RUSTC) dylib.rs
+ $(call REMOVE_DYLIBS,rlib)
+ $(RUSTC) prog.rs && exit 1 || exit 0