summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/msvc-opt-minsize
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make-fulldeps/msvc-opt-minsize')
-rw-r--r--tests/run-make-fulldeps/msvc-opt-minsize/Makefile5
-rw-r--r--tests/run-make-fulldeps/msvc-opt-minsize/foo.rs19
2 files changed, 0 insertions, 24 deletions
diff --git a/tests/run-make-fulldeps/msvc-opt-minsize/Makefile b/tests/run-make-fulldeps/msvc-opt-minsize/Makefile
deleted file mode 100644
index a5f019f24..000000000
--- a/tests/run-make-fulldeps/msvc-opt-minsize/Makefile
+++ /dev/null
@@ -1,5 +0,0 @@
-include ../tools.mk
-
-all:
- $(RUSTC) foo.rs -Copt-level=z 2>&1
- $(call RUN,foo)
diff --git a/tests/run-make-fulldeps/msvc-opt-minsize/foo.rs b/tests/run-make-fulldeps/msvc-opt-minsize/foo.rs
deleted file mode 100644
index 3f5496c08..000000000
--- a/tests/run-make-fulldeps/msvc-opt-minsize/foo.rs
+++ /dev/null
@@ -1,19 +0,0 @@
-#![feature(test)]
-extern crate test;
-
-fn foo(x: i32, y: i32) -> i64 {
- (x + y) as i64
-}
-
-#[inline(never)]
-fn bar() {
- let _f = Box::new(0);
- // This call used to trigger an LLVM bug in opt-level z where the base
- // pointer gets corrupted, see issue #45034
- let y: fn(i32, i32) -> i64 = test::black_box(foo);
- test::black_box(y(1, 2));
-}
-
-fn main() {
- bar();
-}