summaryrefslogtreecommitdiffstats
path: root/tests/run-make/a-b-a-linker-guard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/a-b-a-linker-guard/Makefile')
-rw-r--r--tests/run-make/a-b-a-linker-guard/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/a-b-a-linker-guard/Makefile b/tests/run-make/a-b-a-linker-guard/Makefile
new file mode 100644
index 000000000..43282eae0
--- /dev/null
+++ b/tests/run-make/a-b-a-linker-guard/Makefile
@@ -0,0 +1,16 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test that if we build `b` against a version of `a` that has one set
+# of types, it will not run with a dylib that has a different set of
+# types.
+
+# NOTE(eddyb) this test only works with the `legacy` mangling,
+# and will probably get removed once `legacy` is gone.
+
+all:
+ $(RUSTC) a.rs --cfg x -C prefer-dynamic -Z unstable-options -C symbol-mangling-version=legacy
+ $(RUSTC) b.rs -C prefer-dynamic -Z unstable-options -C symbol-mangling-version=legacy
+ $(call RUN,b)
+ $(RUSTC) a.rs --cfg y -C prefer-dynamic -Z unstable-options -C symbol-mangling-version=legacy
+ $(call FAIL,b)