summaryrefslogtreecommitdiffstats
path: root/tests/run-make/allow-non-lint-warnings-cmdline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/allow-non-lint-warnings-cmdline/Makefile')
-rw-r--r--tests/run-make/allow-non-lint-warnings-cmdline/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/allow-non-lint-warnings-cmdline/Makefile b/tests/run-make/allow-non-lint-warnings-cmdline/Makefile
new file mode 100644
index 000000000..78b9a7b98
--- /dev/null
+++ b/tests/run-make/allow-non-lint-warnings-cmdline/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test that -A warnings makes the 'empty trait list for derive' warning go away
+OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
+
+all: foo
+ test -z '$(OUT)'
+
+# This is just to make sure the above command actually succeeds
+foo:
+ $(RUSTC) foo.rs -A warnings