summaryrefslogtreecommitdiffstats
path: root/tests/run-make/allow-warnings-cmdline-stability/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/allow-warnings-cmdline-stability/Makefile')
-rw-r--r--tests/run-make/allow-warnings-cmdline-stability/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/allow-warnings-cmdline-stability/Makefile b/tests/run-make/allow-warnings-cmdline-stability/Makefile
new file mode 100644
index 000000000..368a39af6
--- /dev/null
+++ b/tests/run-make/allow-warnings-cmdline-stability/Makefile
@@ -0,0 +1,16 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test that -A warnings makes the 'empty trait list for derive' warning go away
+DEP=$(shell $(RUSTC) bar.rs)
+OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
+
+all: foo bar
+ test -z '$(OUT)'
+
+# These are just to ensure that the above commands actually work
+bar:
+ $(RUSTC) bar.rs
+
+foo: bar
+ $(RUSTC) foo.rs -A warnings