summaryrefslogtreecommitdiffstats
path: root/tests/run-make/arguments-non-c-like-enum/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/arguments-non-c-like-enum/Makefile')
-rw-r--r--tests/run-make/arguments-non-c-like-enum/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/arguments-non-c-like-enum/Makefile b/tests/run-make/arguments-non-c-like-enum/Makefile
new file mode 100644
index 000000000..0c8d8bf3a
--- /dev/null
+++ b/tests/run-make/arguments-non-c-like-enum/Makefile
@@ -0,0 +1,8 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) --crate-type=staticlib nonclike.rs
+ $(CC) test.c $(call STATICLIB,nonclike) $(call OUT_EXE,test) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,test)