summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-dynamic-dylib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-dynamic-dylib/Makefile')
-rw-r--r--tests/run-make/c-dynamic-dylib/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/c-dynamic-dylib/Makefile b/tests/run-make/c-dynamic-dylib/Makefile
new file mode 100644
index 000000000..b5bfbc765
--- /dev/null
+++ b/tests/run-make/c-dynamic-dylib/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-macos
+#
+# This hits an assertion in the linker on older versions of osx apparently
+
+all: $(call DYLIB,cfoo)
+ $(RUSTC) foo.rs -C prefer-dynamic
+ $(RUSTC) bar.rs
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,cfoo)
+ $(call FAIL,bar)