summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-dynamic-rlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-dynamic-rlib/Makefile')
-rw-r--r--tests/run-make/c-dynamic-rlib/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/c-dynamic-rlib/Makefile b/tests/run-make/c-dynamic-rlib/Makefile
new file mode 100644
index 000000000..0475bd8ac
--- /dev/null
+++ b/tests/run-make/c-dynamic-rlib/Makefile
@@ -0,0 +1,16 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-macos
+#
+# This hits an assertion in the linker on older versions of osx apparently
+
+# This overrides the LD_LIBRARY_PATH for RUN
+TARGET_RPATH_DIR:=$(TARGET_RPATH_DIR):$(TMPDIR)
+
+all: $(call DYLIB,cfoo)
+ $(RUSTC) foo.rs
+ $(RUSTC) bar.rs
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,cfoo)
+ $(call FAIL,bar)