summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-link-to-rust-dylib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-link-to-rust-dylib/Makefile')
-rw-r--r--tests/run-make/c-link-to-rust-dylib/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/run-make/c-link-to-rust-dylib/Makefile b/tests/run-make/c-link-to-rust-dylib/Makefile
new file mode 100644
index 000000000..2763cb6ed
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-dylib/Makefile
@@ -0,0 +1,18 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(TMPDIR)/$(call BIN,bar)
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,foo)
+ $(call FAIL,bar)
+
+ifdef IS_MSVC
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,bar)
+else
+$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
+ $(CC) bar.c -lfoo -o $(call RUN_BINFILE,bar) -L $(TMPDIR)
+endif
+
+$(call DYLIB,foo): foo.rs
+ $(RUSTC) foo.rs