summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-link-to-rust-staticlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-link-to-rust-staticlib/Makefile')
-rw-r--r--tests/run-make/c-link-to-rust-staticlib/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/c-link-to-rust-staticlib/Makefile b/tests/run-make/c-link-to-rust-staticlib/Makefile
new file mode 100644
index 000000000..e14775f5c
--- /dev/null
+++ b/tests/run-make/c-link-to-rust-staticlib/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-freebsd
+# FIXME
+
+all:
+ $(RUSTC) foo.rs
+ $(CC) bar.c $(call STATICLIB,foo) $(call OUT_EXE,bar) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,bar)
+ rm $(call STATICLIB,foo)
+ $(call RUN,bar)