summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-static-dylib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-static-dylib/Makefile')
-rw-r--r--tests/run-make/c-static-dylib/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/c-static-dylib/Makefile b/tests/run-make/c-static-dylib/Makefile
new file mode 100644
index 000000000..4e23edb6c
--- /dev/null
+++ b/tests/run-make/c-static-dylib/Makefile
@@ -0,0 +1,10 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,cfoo)
+ $(RUSTC) foo.rs -C prefer-dynamic
+ $(RUSTC) bar.rs
+ rm $(call NATIVE_STATICLIB,cfoo)
+ $(call RUN,bar)
+ $(call REMOVE_DYLIBS,foo)
+ $(call FAIL,bar)