summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-static-rlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-static-rlib/Makefile')
-rw-r--r--tests/run-make/c-static-rlib/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/c-static-rlib/Makefile b/tests/run-make/c-static-rlib/Makefile
new file mode 100644
index 000000000..4e351127c
--- /dev/null
+++ b/tests/run-make/c-static-rlib/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,cfoo)
+ $(RUSTC) foo.rs
+ $(RUSTC) bar.rs
+ $(call REMOVE_RLIBS,foo)
+ rm $(call NATIVE_STATICLIB,cfoo)
+ $(call RUN,bar)