summaryrefslogtreecommitdiffstats
path: root/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/c-unwind-abi-catch-lib-panic/Makefile')
-rw-r--r--tests/run-make/c-unwind-abi-catch-lib-panic/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile b/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
new file mode 100644
index 000000000..9c41a5a71
--- /dev/null
+++ b/tests/run-make/c-unwind-abi-catch-lib-panic/Makefile
@@ -0,0 +1,31 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: archive
+ # Compile `main.rs`, which will link into our library, and run it.
+ $(RUSTC) main.rs
+ $(call RUN,main)
+
+ifdef IS_MSVC
+archive: add.o panic.o
+ # Now, create an archive using these two objects.
+ $(AR) crus $(TMPDIR)/add.lib $(TMPDIR)/add.o $(TMPDIR)/panic.o
+else
+archive: add.o panic.o
+ # Now, create an archive using these two objects.
+ $(AR) crus $(TMPDIR)/libadd.a $(TMPDIR)/add.o $(TMPDIR)/panic.o
+endif
+
+# Compile `panic.rs` into an object file.
+#
+# Note that we invoke `rustc` directly, so we may emit an object rather
+# than an archive. We'll do that later.
+panic.o:
+ $(BARE_RUSTC) $(RUSTFLAGS) \
+ --out-dir $(TMPDIR) \
+ --emit=obj panic.rs
+
+# Compile `add.c` into an object file.
+add.o:
+ $(call COMPILE_OBJ,$(TMPDIR)/add.o,add.c)
+