summaryrefslogtreecommitdiffstats
path: root/tests/run-make/cdylib-dylib-linkage
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/cdylib-dylib-linkage')
-rw-r--r--tests/run-make/cdylib-dylib-linkage/Makefile28
-rw-r--r--tests/run-make/cdylib-dylib-linkage/bar.rs5
-rw-r--r--tests/run-make/cdylib-dylib-linkage/foo.c10
-rw-r--r--tests/run-make/cdylib-dylib-linkage/foo.rs13
4 files changed, 56 insertions, 0 deletions
diff --git a/tests/run-make/cdylib-dylib-linkage/Makefile b/tests/run-make/cdylib-dylib-linkage/Makefile
new file mode 100644
index 000000000..51fbfef2d
--- /dev/null
+++ b/tests/run-make/cdylib-dylib-linkage/Makefile
@@ -0,0 +1,28 @@
+# ignore-cross-compile
+include ../tools.mk
+
+TARGET_SYSROOT := $(shell $(RUSTC) --print sysroot)/lib/rustlib/$(TARGET)/lib
+
+ifdef IS_MSVC
+LIBSTD := $(wildcard $(TARGET_SYSROOT)/libstd-*.dll.lib)
+else
+LIBSTD := $(wildcard $(TARGET_SYSROOT)/$(call DYLIB_GLOB,std))
+STD := $(basename $(patsubst lib%,%, $(notdir $(LIBSTD))))
+endif
+
+all: $(call RUN_BINFILE,foo)
+ $(call RUN,foo)
+
+ifdef IS_MSVC
+CLIBS := $(TMPDIR)/foo.dll.lib $(TMPDIR)/bar.dll.lib $(LIBSTD)
+$(call RUN_BINFILE,foo): $(call DYLIB,foo)
+ $(CC) $(CFLAGS) foo.c $(CLIBS) $(call OUT_EXE,foo)
+else
+CLIBS := -lfoo -lbar -l$(STD) -L $(TMPDIR) -L $(TARGET_SYSROOT)
+$(call RUN_BINFILE,foo): $(call DYLIB,foo)
+ $(CC) $(CFLAGS) foo.c $(CLIBS) -o $(call RUN_BINFILE,foo)
+endif
+
+$(call DYLIB,foo):
+ $(RUSTC) -C prefer-dynamic bar.rs
+ $(RUSTC) foo.rs
diff --git a/tests/run-make/cdylib-dylib-linkage/bar.rs b/tests/run-make/cdylib-dylib-linkage/bar.rs
new file mode 100644
index 000000000..b3a7539ab
--- /dev/null
+++ b/tests/run-make/cdylib-dylib-linkage/bar.rs
@@ -0,0 +1,5 @@
+#![crate_type = "dylib"]
+
+pub fn bar() {
+ println!("hello!");
+}
diff --git a/tests/run-make/cdylib-dylib-linkage/foo.c b/tests/run-make/cdylib-dylib-linkage/foo.c
new file mode 100644
index 000000000..154f9682e
--- /dev/null
+++ b/tests/run-make/cdylib-dylib-linkage/foo.c
@@ -0,0 +1,10 @@
+#include <assert.h>
+
+extern void foo();
+extern unsigned bar(unsigned a, unsigned b);
+
+int main() {
+ foo();
+ assert(bar(1, 2) == 3);
+ return 0;
+}
diff --git a/tests/run-make/cdylib-dylib-linkage/foo.rs b/tests/run-make/cdylib-dylib-linkage/foo.rs
new file mode 100644
index 000000000..c4069495a
--- /dev/null
+++ b/tests/run-make/cdylib-dylib-linkage/foo.rs
@@ -0,0 +1,13 @@
+#![crate_type = "cdylib"]
+
+extern crate bar;
+
+#[no_mangle]
+pub extern "C" fn foo() {
+ bar::bar();
+}
+
+#[no_mangle]
+pub extern "C" fn bar(a: u32, b: u32) -> u32 {
+ a + b
+}