summaryrefslogtreecommitdiffstats
path: root/tests/run-make/cdylib-fewer-symbols/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/cdylib-fewer-symbols/Makefile')
-rw-r--r--tests/run-make/cdylib-fewer-symbols/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/cdylib-fewer-symbols/Makefile b/tests/run-make/cdylib-fewer-symbols/Makefile
new file mode 100644
index 000000000..4e08f979c
--- /dev/null
+++ b/tests/run-make/cdylib-fewer-symbols/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+# Test that allocator-related symbols don't show up as exported from a cdylib as
+# they're internal to Rust and not part of the public ABI.
+
+include ../tools.mk
+
+# ignore-windows
+# FIXME: The __rdl_ and __rust_ symbol still remains, no matter using MSVC or GNU
+# See https://github.com/rust-lang/rust/pull/46207#issuecomment-347561753
+
+all:
+ $(RUSTC) foo.rs
+ nm -g "$(call DYLIB,foo)" | $(CGREP) -v __rdl_ __rde_ __rg_ __rust_