summaryrefslogtreecommitdiffstats
path: root/tests/run-make/compiler-lookup-paths-2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/compiler-lookup-paths-2/Makefile')
-rw-r--r--tests/run-make/compiler-lookup-paths-2/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/compiler-lookup-paths-2/Makefile b/tests/run-make/compiler-lookup-paths-2/Makefile
new file mode 100644
index 000000000..d4ff7d8da
--- /dev/null
+++ b/tests/run-make/compiler-lookup-paths-2/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+all:
+ mkdir -p $(TMPDIR)/a $(TMPDIR)/b
+ $(RUSTC) a.rs && mv $(TMPDIR)/liba.rlib $(TMPDIR)/a
+ $(RUSTC) b.rs -L $(TMPDIR)/a && mv $(TMPDIR)/libb.rlib $(TMPDIR)/b
+ $(RUSTC) c.rs -L crate=$(TMPDIR)/b -L dependency=$(TMPDIR)/a \
+ && exit 1 || exit 0