summaryrefslogtreecommitdiffstats
path: root/tests/run-make/compiler-rt-works-on-mingw/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/compiler-rt-works-on-mingw/Makefile')
-rw-r--r--tests/run-make/compiler-rt-works-on-mingw/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/compiler-rt-works-on-mingw/Makefile b/tests/run-make/compiler-rt-works-on-mingw/Makefile
new file mode 100644
index 000000000..74917570a
--- /dev/null
+++ b/tests/run-make/compiler-rt-works-on-mingw/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# only-windows-gnu
+
+all:
+ $(CXX) foo.cpp -c -o $(TMPDIR)/foo.o
+ $(AR) crus $(TMPDIR)/libfoo.a $(TMPDIR)/foo.o
+ $(RUSTC) foo.rs -lfoo -lstdc++
+ $(call RUN,foo)