summaryrefslogtreecommitdiffstats
path: root/tests/run-make/const_fn_mir/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/const_fn_mir/Makefile')
-rw-r--r--tests/run-make/const_fn_mir/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/const_fn_mir/Makefile b/tests/run-make/const_fn_mir/Makefile
new file mode 100644
index 000000000..ad5695093
--- /dev/null
+++ b/tests/run-make/const_fn_mir/Makefile
@@ -0,0 +1,10 @@
+include ../../run-make-fulldeps/tools.mk
+
+all:
+ $(RUSTC) main.rs --emit=mir -o "$(TMPDIR)"/dump.mir
+
+ifdef RUSTC_BLESS_TEST
+ cp "$(TMPDIR)"/dump.mir dump.mir
+else
+ $(DIFF) dump.mir "$(TMPDIR)"/dump.mir
+endif