summaryrefslogtreecommitdiffstats
path: root/tests/run-make/crate-data-smoke/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/crate-data-smoke/Makefile')
-rw-r--r--tests/run-make/crate-data-smoke/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/crate-data-smoke/Makefile b/tests/run-make/crate-data-smoke/Makefile
new file mode 100644
index 000000000..a453f65ff
--- /dev/null
+++ b/tests/run-make/crate-data-smoke/Makefile
@@ -0,0 +1,10 @@
+include ../tools.mk
+
+all:
+ [ `$(RUSTC) --print crate-name crate.rs` = "foo" ]
+ [ `$(RUSTC) --print file-names crate.rs` = "$(call BIN,foo)" ]
+ [ `$(RUSTC) --print file-names --crate-type=lib \
+ --test crate.rs` = "$(call BIN,foo)" ]
+ [ `$(RUSTC) --print file-names --test lib.rs` = "$(call BIN,mylib)" ]
+ $(RUSTC) --print file-names lib.rs
+ $(RUSTC) --print file-names rlib.rs