summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info-spaces/Makefile.foo
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/dep-info-spaces/Makefile.foo')
-rw-r--r--tests/run-make/dep-info-spaces/Makefile.foo7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/dep-info-spaces/Makefile.foo b/tests/run-make/dep-info-spaces/Makefile.foo
new file mode 100644
index 000000000..80a5d4333
--- /dev/null
+++ b/tests/run-make/dep-info-spaces/Makefile.foo
@@ -0,0 +1,7 @@
+LIB := $(shell $(RUSTC) --print file-names --crate-type=lib $(TMPDIR)/lib.rs)
+
+$(TMPDIR)/$(LIB):
+ $(RUSTC) --emit link,dep-info --crate-type=lib $(TMPDIR)/lib.rs
+ touch $(TMPDIR)/done
+
+-include $(TMPDIR)/lib.d