summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info/Makefile.foo
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/dep-info/Makefile.foo')
-rw-r--r--tests/run-make/dep-info/Makefile.foo7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/dep-info/Makefile.foo b/tests/run-make/dep-info/Makefile.foo
new file mode 100644
index 000000000..e5df31f88
--- /dev/null
+++ b/tests/run-make/dep-info/Makefile.foo
@@ -0,0 +1,7 @@
+LIB := $(shell $(RUSTC) --print file-names --crate-type=lib lib.rs)
+
+$(TMPDIR)/$(LIB):
+ $(RUSTC) --emit dep-info,link --crate-type=lib lib.rs
+ touch $(TMPDIR)/done
+
+-include $(TMPDIR)/foo.d