summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-info/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/dep-info/Makefile')
-rw-r--r--tests/run-make/dep-info/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/run-make/dep-info/Makefile b/tests/run-make/dep-info/Makefile
new file mode 100644
index 000000000..c76f43a8e
--- /dev/null
+++ b/tests/run-make/dep-info/Makefile
@@ -0,0 +1,25 @@
+include ../tools.mk
+
+# ignore-windows
+# ignore-freebsd
+# FIXME: on windows `rustc --dep-info` produces Makefile dependency with
+# windows native paths (e.g. `c:\path\to\libfoo.a`)
+# but msys make seems to fail to recognize such paths, so test fails.
+
+all:
+ cp *.rs $(TMPDIR)
+ $(RUSTC) --emit dep-info,link --crate-type=lib $(TMPDIR)/lib.rs
+ sleep 2
+ touch $(TMPDIR)/foo.rs
+ -rm -f $(TMPDIR)/done
+ $(MAKE) -drf Makefile.foo
+ sleep 2
+ rm $(TMPDIR)/done
+ pwd
+ $(MAKE) -drf Makefile.foo
+ rm $(TMPDIR)/done && exit 1 || exit 0
+
+ # When a source file is deleted `make` should still work
+ rm $(TMPDIR)/bar.rs
+ cp $(TMPDIR)/lib2.rs $(TMPDIR)/lib.rs
+ $(MAKE) -drf Makefile.foo