summaryrefslogtreecommitdiffstats
path: root/tests/run-make/emit-stack-sizes/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/emit-stack-sizes/Makefile')
-rw-r--r--tests/run-make/emit-stack-sizes/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/emit-stack-sizes/Makefile b/tests/run-make/emit-stack-sizes/Makefile
new file mode 100644
index 000000000..f636ebd28
--- /dev/null
+++ b/tests/run-make/emit-stack-sizes/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+# ignore-windows
+# ignore-macos
+#
+# This feature only works when the output object format is ELF so we ignore
+# macOS and Windows
+
+# check that the .stack_sizes section is generated
+all:
+ $(RUSTC) -C opt-level=3 -Z emit-stack-sizes --emit=obj foo.rs
+ size -A $(TMPDIR)/foo.o | $(CGREP) .stack_sizes