summaryrefslogtreecommitdiffstats
path: root/tests/run-make/exit-code/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/exit-code/Makefile')
-rw-r--r--tests/run-make/exit-code/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/exit-code/Makefile b/tests/run-make/exit-code/Makefile
new file mode 100644
index 000000000..6458b7168
--- /dev/null
+++ b/tests/run-make/exit-code/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) success.rs; [ $$? -eq 0 ]
+ $(RUSTC) --invalid-arg-foo; [ $$? -eq 1 ]
+ $(RUSTC) compile-error.rs; [ $$? -eq 1 ]
+ $(RUSTC) -Ztreat-err-as-bug compile-error.rs; [ $$? -eq 101 ]
+ $(RUSTDOC) -o $(TMPDIR)/exit-code success.rs; [ $$? -eq 0 ]
+ $(RUSTDOC) --invalid-arg-foo; [ $$? -eq 1 ]
+ $(RUSTDOC) compile-error.rs; [ $$? -eq 1 ]
+ $(RUSTDOC) lint-failure.rs; [ $$? -eq 1 ]