summaryrefslogtreecommitdiffstats
path: root/tests/run-make/extern-fn-reachable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/extern-fn-reachable/Makefile')
-rw-r--r--tests/run-make/extern-fn-reachable/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/run-make/extern-fn-reachable/Makefile b/tests/run-make/extern-fn-reachable/Makefile
new file mode 100644
index 000000000..3297251bf
--- /dev/null
+++ b/tests/run-make/extern-fn-reachable/Makefile
@@ -0,0 +1,26 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows-msvc
+
+NM=nm -D
+
+ifeq ($(UNAME),Darwin)
+NM=nm -gU
+endif
+
+ifdef IS_WINDOWS
+NM=nm -g
+endif
+
+# This overrides the LD_LIBRARY_PATH for RUN
+TARGET_RPATH_DIR:=$(TARGET_RPATH_DIR):$(TMPDIR)
+
+all:
+ $(RUSTC) dylib.rs -o $(TMPDIR)/libdylib.so -C prefer-dynamic
+
+ [ "$$($(NM) $(TMPDIR)/libdylib.so | grep -v __imp_ | grep -c fun1)" -eq "1" ]
+ [ "$$($(NM) $(TMPDIR)/libdylib.so | grep -v __imp_ | grep -c fun2)" -eq "1" ]
+ [ "$$($(NM) $(TMPDIR)/libdylib.so | grep -v __imp_ | grep -c fun3)" -eq "1" ]
+ [ "$$($(NM) $(TMPDIR)/libdylib.so | grep -v __imp_ | grep -c fun4)" -eq "1" ]
+ [ "$$($(NM) $(TMPDIR)/libdylib.so | grep -v __imp_ | grep -c fun5)" -eq "1" ]