summaryrefslogtreecommitdiffstats
path: root/tests/run-make/extern-multiple-copies/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/extern-multiple-copies/Makefile')
-rw-r--r--tests/run-make/extern-multiple-copies/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/extern-multiple-copies/Makefile b/tests/run-make/extern-multiple-copies/Makefile
new file mode 100644
index 000000000..b0b84278e
--- /dev/null
+++ b/tests/run-make/extern-multiple-copies/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) foo1.rs
+ $(RUSTC) foo2.rs
+ mkdir $(TMPDIR)/foo
+ cp $(TMPDIR)/libfoo1.rlib $(TMPDIR)/foo/libfoo1.rlib
+ $(RUSTC) bar.rs --extern foo1=$(TMPDIR)/libfoo1.rlib -L $(TMPDIR)/foo