summaryrefslogtreecommitdiffstats
path: root/tests/run-make/fmt-write-bloat
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/fmt-write-bloat')
-rw-r--r--tests/run-make/fmt-write-bloat/Makefile25
-rw-r--r--tests/run-make/fmt-write-bloat/main.rs32
2 files changed, 57 insertions, 0 deletions
diff --git a/tests/run-make/fmt-write-bloat/Makefile b/tests/run-make/fmt-write-bloat/Makefile
new file mode 100644
index 000000000..07e6e025e
--- /dev/null
+++ b/tests/run-make/fmt-write-bloat/Makefile
@@ -0,0 +1,25 @@
+include ../../run-make-fulldeps/tools.mk
+
+# ignore-windows
+
+ifeq ($(shell $(RUSTC) -vV | grep 'host: $(TARGET)'),)
+
+# Don't run this test when cross compiling.
+all:
+
+else
+
+NM = nm
+
+PANIC_SYMS = panic_bounds_check pad_integral Display Debug
+
+# Allow for debug_assert!() in debug builds of std.
+ifdef NO_DEBUG_ASSERTIONS
+PANIC_SYMS += panicking panic_fmt
+endif
+
+all: main.rs
+ $(RUSTC) $< -O
+ $(NM) $(call RUN_BINFILE,main) | $(CGREP) -v $(PANIC_SYMS)
+
+endif
diff --git a/tests/run-make/fmt-write-bloat/main.rs b/tests/run-make/fmt-write-bloat/main.rs
new file mode 100644
index 000000000..e86c48014
--- /dev/null
+++ b/tests/run-make/fmt-write-bloat/main.rs
@@ -0,0 +1,32 @@
+#![feature(lang_items)]
+#![feature(start)]
+#![no_std]
+
+use core::fmt;
+use core::fmt::Write;
+
+#[link(name = "c")]
+extern "C" {}
+
+struct Dummy;
+
+impl fmt::Write for Dummy {
+ #[inline(never)]
+ fn write_str(&mut self, _: &str) -> fmt::Result {
+ Ok(())
+ }
+}
+
+#[start]
+fn main(_: isize, _: *const *const u8) -> isize {
+ let _ = writeln!(Dummy, "Hello World");
+ 0
+}
+
+#[lang = "eh_personality"]
+fn eh_personality() {}
+
+#[panic_handler]
+fn panic(_: &core::panic::PanicInfo) -> ! {
+ loop {}
+}