summaryrefslogtreecommitdiffstats
path: root/tests/run-make/foreign-double-unwind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/foreign-double-unwind/Makefile')
-rw-r--r--tests/run-make/foreign-double-unwind/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/foreign-double-unwind/Makefile b/tests/run-make/foreign-double-unwind/Makefile
new file mode 100644
index 000000000..f20fe3ce6
--- /dev/null
+++ b/tests/run-make/foreign-double-unwind/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: foo
+ $(call RUN,foo) | $(CGREP) -v unreachable
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)