summaryrefslogtreecommitdiffstats
path: root/tests/run-make/foreign-exceptions/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/foreign-exceptions/Makefile')
-rw-r--r--tests/run-make/foreign-exceptions/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/foreign-exceptions/Makefile b/tests/run-make/foreign-exceptions/Makefile
new file mode 100644
index 000000000..a8e20ffb1
--- /dev/null
+++ b/tests/run-make/foreign-exceptions/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: foo
+ $(call RUN,foo)
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)