summaryrefslogtreecommitdiffstats
path: root/tests/run-make/foreign-rust-exceptions/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/foreign-rust-exceptions/Makefile')
-rw-r--r--tests/run-make/foreign-rust-exceptions/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/foreign-rust-exceptions/Makefile b/tests/run-make/foreign-rust-exceptions/Makefile
new file mode 100644
index 000000000..0d007bf1c
--- /dev/null
+++ b/tests/run-make/foreign-rust-exceptions/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+# ignore-i686-pc-windows-gnu
+
+# This test doesn't work on 32-bit MinGW as cdylib has its own copy of unwinder
+# so cross-DLL unwinding does not work.
+
+include ../tools.mk
+
+all:
+ $(RUSTC) bar.rs --crate-type=cdylib
+ $(RUSTC) foo.rs
+ $(call RUN,foo) 2>&1 | $(CGREP) "Rust cannot catch foreign exceptions"