summaryrefslogtreecommitdiffstats
path: root/tests/run-make/fpic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/fpic/Makefile')
-rw-r--r--tests/run-make/fpic/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/fpic/Makefile b/tests/run-make/fpic/Makefile
new file mode 100644
index 000000000..c38dd8d6e
--- /dev/null
+++ b/tests/run-make/fpic/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# ignore-macos
+
+# Test for #39529.
+# `-z text` causes ld to error if there are any non-PIC sections
+
+all:
+ $(RUSTC) hello.rs -C link-args=-Wl,-z,text