summaryrefslogtreecommitdiffstats
path: root/tests/run-make/glibc-staticlib-args/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/glibc-staticlib-args/Makefile')
-rw-r--r--tests/run-make/glibc-staticlib-args/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/glibc-staticlib-args/Makefile b/tests/run-make/glibc-staticlib-args/Makefile
new file mode 100644
index 000000000..cad6c049e
--- /dev/null
+++ b/tests/run-make/glibc-staticlib-args/Makefile
@@ -0,0 +1,13 @@
+# ignore-cross-compile
+# only-gnu
+# only-linux
+
+include ../tools.mk
+
+# This ensures that std::env::args works in a library called from C on glibc Linux.
+
+all:
+ $(RUSTC) --crate-type=staticlib library.rs
+ $(CC) program.c $(call STATICLIB,library) $(call OUT_EXE,program) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,program)