summaryrefslogtreecommitdiffstats
path: root/tests/run-make/hir-tree/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/hir-tree/Makefile')
-rw-r--r--tests/run-make/hir-tree/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/hir-tree/Makefile b/tests/run-make/hir-tree/Makefile
new file mode 100644
index 000000000..b0450ea4b
--- /dev/null
+++ b/tests/run-make/hir-tree/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+# Test that hir-tree output doesn't crash and includes
+# the string constant we would expect to see.
+
+all:
+ $(RUSTC) -o $(TMPDIR)/input.hir -Z unpretty=hir-tree input.rs
+ $(CGREP) '"Hello, Rustaceans!\n"' < $(TMPDIR)/input.hir