summaryrefslogtreecommitdiffstats
path: root/tests/run-make/interdependent-c-libraries/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/interdependent-c-libraries/Makefile')
-rw-r--r--tests/run-make/interdependent-c-libraries/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make/interdependent-c-libraries/Makefile b/tests/run-make/interdependent-c-libraries/Makefile
new file mode 100644
index 000000000..53a696d82
--- /dev/null
+++ b/tests/run-make/interdependent-c-libraries/Makefile
@@ -0,0 +1,15 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# The rust crate foo will link to the native library foo, while the rust crate
+# bar will link to the native library bar. There is also a dependency between
+# the native library bar to the natibe library foo.
+#
+# This test ensures that the ordering of -lfoo and -lbar on the command line is
+# correct to complete the linkage. If passed as "-lfoo -lbar", then the 'foo'
+# library will be stripped out, and the linkage will fail.
+
+all: $(call NATIVE_STATICLIB,foo) $(call NATIVE_STATICLIB,bar)
+ $(RUSTC) foo.rs
+ $(RUSTC) bar.rs
+ $(RUSTC) main.rs --print link-args