summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-109934-lto-debuginfo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-109934-lto-debuginfo/Makefile')
-rw-r--r--tests/run-make/issue-109934-lto-debuginfo/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/issue-109934-lto-debuginfo/Makefile b/tests/run-make/issue-109934-lto-debuginfo/Makefile
new file mode 100644
index 000000000..3b7a99d3d
--- /dev/null
+++ b/tests/run-make/issue-109934-lto-debuginfo/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# With the upgrade to LLVM 16, this was getting:
+#
+# error: Cannot represent a difference across sections
+#
+# The error stemmed from DI function definitions under type scopes, fixed by
+# only declaring in type scope and defining the subprogram elsewhere.
+
+all:
+ $(RUSTC) lib.rs --test -C lto=fat -C debuginfo=2 -C incremental=$(TMPDIR)/inc-fat