summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-11908/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-11908/Makefile')
-rw-r--r--tests/run-make/issue-11908/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make/issue-11908/Makefile b/tests/run-make/issue-11908/Makefile
new file mode 100644
index 000000000..38586662f
--- /dev/null
+++ b/tests/run-make/issue-11908/Makefile
@@ -0,0 +1,22 @@
+# ignore-cross-compile
+# This test ensures that if you have the same rlib or dylib at two locations
+# in the same path that you don't hit an assertion in the compiler.
+#
+# Note that this relies on `liburl` to be in the path somewhere else,
+# and then our aux-built libraries will collide with liburl (they have
+# the same version listed)
+
+include ../tools.mk
+
+all:
+ mkdir $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=dylib -C prefer-dynamic
+ mv $(call DYLIB,foo) $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=dylib -C prefer-dynamic
+ $(RUSTC) bar.rs -L $(TMPDIR)/other
+ rm -rf $(TMPDIR)
+ mkdir -p $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=rlib
+ mv $(TMPDIR)/libfoo.rlib $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=rlib
+ $(RUSTC) bar.rs -L $(TMPDIR)/other