summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-14500/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-14500/Makefile')
-rw-r--r--tests/run-make/issue-14500/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make/issue-14500/Makefile b/tests/run-make/issue-14500/Makefile
new file mode 100644
index 000000000..eeab48de3
--- /dev/null
+++ b/tests/run-make/issue-14500/Makefile
@@ -0,0 +1,15 @@
+include ../tools.mk
+
+# ignore-cross-compile
+
+# Test to make sure that reachable extern fns are always available in final
+# productcs, including when LTO is used. In this test, the `foo` crate has a
+# reahable symbol, and is a dependency of the `bar` crate. When the `bar` crate
+# is compiled with LTO, it shouldn't strip the symbol from `foo`, and that's the
+# only way that `foo.c` will successfully compile.
+
+all:
+ $(RUSTC) foo.rs --crate-type=rlib
+ $(RUSTC) bar.rs --crate-type=staticlib -C lto -L. -o $(TMPDIR)/libbar.a
+ $(CC) foo.c $(TMPDIR)/libbar.a $(EXTRACFLAGS) $(call OUT_EXE,foo)
+ $(call RUN,foo)