summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-15460/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-15460/Makefile')
-rw-r--r--tests/run-make/issue-15460/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/issue-15460/Makefile b/tests/run-make/issue-15460/Makefile
new file mode 100644
index 000000000..a36a085fa
--- /dev/null
+++ b/tests/run-make/issue-15460/Makefile
@@ -0,0 +1,7 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) foo.rs -C extra-filename=-383hf8 -C prefer-dynamic
+ $(RUSTC) bar.rs
+ $(call RUN,bar)