summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-20626/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-20626/Makefile')
-rw-r--r--tests/run-make/issue-20626/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/issue-20626/Makefile b/tests/run-make/issue-20626/Makefile
new file mode 100644
index 000000000..63eee910a
--- /dev/null
+++ b/tests/run-make/issue-20626/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test output to be four
+# The original error only occurred when printing, not when comparing using assert!
+
+all:
+ $(RUSTC) foo.rs -O
+ [ `$(call RUN,foo)` = "4" ]