summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-26006/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-26006/Makefile')
-rw-r--r--tests/run-make/issue-26006/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/issue-26006/Makefile b/tests/run-make/issue-26006/Makefile
new file mode 100644
index 000000000..b679c1215
--- /dev/null
+++ b/tests/run-make/issue-26006/Makefile
@@ -0,0 +1,17 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+
+OUT := $(TMPDIR)/out
+
+all: time
+
+time: libc
+ mkdir -p $(OUT)/time $(OUT)/time/deps
+ ln -sf $(OUT)/libc/liblibc.rlib $(OUT)/time/deps/
+ $(RUSTC) in/time/lib.rs -Ldependency=$(OUT)/time/deps/
+
+libc:
+ mkdir -p $(OUT)/libc
+ $(RUSTC) in/libc/lib.rs --crate-name=libc -Cmetadata=foo -o $(OUT)/libc/liblibc.rlib