summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-28766
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-28766')
-rw-r--r--tests/run-make/issue-28766/Makefile5
-rw-r--r--tests/run-make/issue-28766/foo.rs8
-rw-r--r--tests/run-make/issue-28766/main.rs7
3 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/issue-28766/Makefile b/tests/run-make/issue-28766/Makefile
new file mode 100644
index 000000000..96d0bdc2b
--- /dev/null
+++ b/tests/run-make/issue-28766/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) -O foo.rs
+ $(RUSTC) -O -L $(TMPDIR) main.rs
diff --git a/tests/run-make/issue-28766/foo.rs b/tests/run-make/issue-28766/foo.rs
new file mode 100644
index 000000000..1dcabe42d
--- /dev/null
+++ b/tests/run-make/issue-28766/foo.rs
@@ -0,0 +1,8 @@
+#![crate_type="lib"]
+pub struct Foo(());
+
+impl Foo {
+ pub fn new() -> Foo {
+ Foo(())
+ }
+}
diff --git a/tests/run-make/issue-28766/main.rs b/tests/run-make/issue-28766/main.rs
new file mode 100644
index 000000000..de12b1fd9
--- /dev/null
+++ b/tests/run-make/issue-28766/main.rs
@@ -0,0 +1,7 @@
+#![crate_type="lib"]
+extern crate foo;
+use foo::Foo;
+
+pub fn crash() -> Box<Foo> {
+ Box::new(Foo::new())
+}