summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-36710/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-36710/Makefile')
-rw-r--r--tests/run-make/issue-36710/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/run-make/issue-36710/Makefile b/tests/run-make/issue-36710/Makefile
new file mode 100644
index 000000000..d6145c071
--- /dev/null
+++ b/tests/run-make/issue-36710/Makefile
@@ -0,0 +1,17 @@
+# ignore-none no-std is not supported
+# ignore-wasm32 FIXME: don't attempt to compile C++ to WASM
+# ignore-wasm64 FIXME: don't attempt to compile C++ to WASM
+# ignore-nvptx64-nvidia-cuda FIXME: can't find crate for `std`
+# ignore-musl FIXME: this makefile needs teaching how to use a musl toolchain
+# (see dist-i586-gnu-i586-i686-musl Dockerfile)
+
+include ../../run-make-fulldeps/tools.mk
+
+all: foo
+ $(call RUN,foo)
+
+foo: foo.rs $(call NATIVE_STATICLIB,foo)
+ $(RUSTC) $< -lfoo $(EXTRARSCXXFLAGS) --target $(TARGET)
+
+$(TMPDIR)/libfoo.o: foo.cpp
+ $(call COMPILE_OBJ_CXX,$@,$<)