summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-37839
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-37839')
-rw-r--r--tests/run-make/issue-37839/Makefile7
-rw-r--r--tests/run-make/issue-37839/a.rs2
-rw-r--r--tests/run-make/issue-37839/b.rs2
-rw-r--r--tests/run-make/issue-37839/c.rs2
4 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/issue-37839/Makefile b/tests/run-make/issue-37839/Makefile
new file mode 100644
index 000000000..6bad27b7b
--- /dev/null
+++ b/tests/run-make/issue-37839/Makefile
@@ -0,0 +1,7 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) a.rs && $(RUSTC) b.rs
+ $(BARE_RUSTC) c.rs -L dependency=$(TMPDIR) --extern b=$(TMPDIR)/libb.rlib \
+ --out-dir=$(TMPDIR)
diff --git a/tests/run-make/issue-37839/a.rs b/tests/run-make/issue-37839/a.rs
new file mode 100644
index 000000000..b5dffac3f
--- /dev/null
+++ b/tests/run-make/issue-37839/a.rs
@@ -0,0 +1,2 @@
+#![allow(unused)]
+#![crate_type = "proc-macro"]
diff --git a/tests/run-make/issue-37839/b.rs b/tests/run-make/issue-37839/b.rs
new file mode 100644
index 000000000..355d2b165
--- /dev/null
+++ b/tests/run-make/issue-37839/b.rs
@@ -0,0 +1,2 @@
+#![crate_type = "lib"]
+#[macro_use] extern crate a;
diff --git a/tests/run-make/issue-37839/c.rs b/tests/run-make/issue-37839/c.rs
new file mode 100644
index 000000000..4c7ce01b6
--- /dev/null
+++ b/tests/run-make/issue-37839/c.rs
@@ -0,0 +1,2 @@
+#![crate_type = "lib"]
+extern crate b;