summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-51671/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-51671/Makefile')
-rw-r--r--tests/run-make/issue-51671/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/issue-51671/Makefile b/tests/run-make/issue-51671/Makefile
new file mode 100644
index 000000000..c93645369
--- /dev/null
+++ b/tests/run-make/issue-51671/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# ignore-windows-msvc
+
+all:
+ $(RUSTC) --emit=obj app.rs
+ nm $(TMPDIR)/app.o | $(CGREP) rust_begin_unwind
+ nm $(TMPDIR)/app.o | $(CGREP) rust_eh_personality
+ nm $(TMPDIR)/app.o | $(CGREP) __rg_oom