summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-68794-textrel-on-minimal-lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/issue-68794-textrel-on-minimal-lib/Makefile')
-rw-r--r--tests/run-make/issue-68794-textrel-on-minimal-lib/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/run-make/issue-68794-textrel-on-minimal-lib/Makefile b/tests/run-make/issue-68794-textrel-on-minimal-lib/Makefile
new file mode 100644
index 000000000..6140b39c0
--- /dev/null
+++ b/tests/run-make/issue-68794-textrel-on-minimal-lib/Makefile
@@ -0,0 +1,18 @@
+# ignore-cross-compile
+# Regression test for issue #68794
+#
+# Verify that no text relocations are accidentally introduced by linking a
+# minimal rust staticlib.
+#
+# The test links a rust static library into a shared library, and checks that
+# the linker doesn't have to flag the resulting file as containing TEXTRELs.
+
+include ../tools.mk
+
+# only-linux
+
+all:
+ $(RUSTC) foo.rs
+ $(CC) bar.c $(call STATICLIB,foo) -fPIC -shared -o $(call DYLIB,bar) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ readelf -d $(call DYLIB,bar) | grep TEXTREL; test $$? -eq 1